You are using an unsupported browser. Please update your browser to the latest version on or before July 31, 2020.
close
Home > Learner FAQ > Course Set Up > System Requirements
System Requirements
print icon

To use BenchPrep, you'll need a stable internet connection on a device with the ability to run modern browsers easily. Google Chrome is our recommended browser, but Mozilla Firefox, Safari, and Edge are all compatible.*

 

*Please note: Support is for the current version of the browser and up to two previous versions.

 

To use BenchPrep on a mobile device, users will need iOS 14 or above or Android 11 and above. The BenchPrep Companion app is compatible with the iPhone, iPad, iPod touch, Kindle, as well as all Android phones and tablets. See the article "Using BenchPrep on Your Mobile Device" for more information. 

 

Be sure to keep your browser up-to-date to be able to use all features. For the optimal experience, keep your browser set to display the page (zoom) at 100% from within your settings.

Feedback
2 out of 4 found this helpful

scroll to top icon